YouTube plugin not working

If something seems really buggy, report it here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

YouTube plugin not working

Postby Dave81 » Sun May 19 2019 13:52

Hello all,
after a complete reinstall of Volumio I have problems with Youtube.
Previously everything was ok (same version of Volumio and plugin), after reinstall Youtube doesn't work at all always throwing this error on the console:

Code: Select all
2019-05-19T12:09:48.613Z - info: CoreCommandRouter::executeOnPlugin: youtube , handleBrowseUri
2019-05-19T12:09:48.614Z - info: handleBrowseUri: youtube
2019-05-19T12:09:53.748Z - error: Access Not Configured. YouTube Data API has not been used in project 119103001349 before or it is disabled. Enable it by visiting https://console.developers.google.com/apis/api/youtube.googleapis.com/overview?project=119103001349 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry.
Error: Access Not Configured. YouTube Data API has not been used in project 119103001349 before or it is disabled. Enable it by visiting https://console.developers.google.com/apis/api/youtube.googleapis.com/overview?project=119103001349 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry.
    at Request._callback (/data/plugins/music_service/youtube/node_modules/google-auth-library/lib/transporters.js:85:15)
    at Request.self.callback (/data/plugins/music_service/youtube/node_modules/request/request.js:185:22)
    at emitTwo (events.js:126:13)
    at Request.emit (events.js:214:7)
    at Request.<anonymous> (/data/plugins/music_service/youtube/node_modules/request/request.js:1161:10)
    at emitOne (events.js:116:13)
    at Request.emit (events.js:211:7)
    at IncomingMessage.<anonymous> (/data/plugins/music_service/youtube/node_modules/request/request.js:1083:12)
    at Object.onceWrapper (events.js:313:30)
    at emitNone (events.js:111:20)
    at IncomingMessage.emit (events.js:208:7)
    at endReadableNT (_stream_readable.js:1064:12)
    at _combinedTickCallback (internal/process/next_tick.js:138:11)
    at process._tickCallback (internal/process/next_tick.js:180:9)


My Volumio version is: 2.575
My youtube plugin version is: 0.0.9

Account access seems to be correctly configured on google.
Should Volumio be present on apps list on my google account?
https://myaccount.google.com/permission ... medium=web

I have seen other threads related to his topic but all seems old and without a response.
https://github.com/volumio/volumio-plugins/issues/228
https://github.com/volumio/volumio-plugins/issues/163
youtube-playback-addon-not-working-513-log-t11301.html

Is anyone facing this problem too?

Thanks,
Davide
Random avatar
Dave81
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat May 18 2019 09:25

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


YouTube plugin not working

Postby Dave81 » Tue May 28 2019 19:38

don't know why but today it started working again...
the only difference is that when I have added the device on google account I also received a confirmation mail from Google.

Thanks
Dave
Random avatar
Dave81
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat May 18 2019 09:25


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest