Youtube Plugin (Failed to Decode Video)

If something seems really buggy, report it here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Youtube Plugin (Failed to Decode Video)

Postby owencape2 » Sat Jun 15 2019 20:57

I have been trying to use the youtube plugin on volumio but it has not been working cause this error. Please help if you know anything. Thanks
volumio error.PNG
volumio error.PNG (71.63 KiB) Viewed 1932 times
Random avatar
owencape2
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Sat Jun 15 2019 20:51

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Youtube Plugin (Failed to Decode Video)

Postby zauselratte » Sun Jun 16 2019 11:36

I have the same probs :(
Random avatar
zauselratte
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Sun Jun 16 2019 11:29


Youtube Plugin (Failed to Decode Video)

Postby Medul » Sun Jun 16 2019 19:54

I Have the same problem. And it's the same thing for Spotify.
Random avatar
Medul
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Sun Jun 16 2019 19:53


Youtube Plugin (Failed to Decode Video)

Postby CherryDT » Mon Jun 17 2019 06:56

For me it's only YouTube, not Spotify, and only some videos

But it seems the source of this problem is this: https://github.com/fent/node-ytdl-core/issues/434

A solution (requires modifying the YT plugin) is here: https://github.com/fent/node-ytdl-core/ ... -502083412
Random avatar
CherryDT
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Mon Jun 17 2019 05:48


Youtube Plugin (Failed to Decode Video)

Postby arczangel » Mon Jul 08 2019 13:31

Same here. Same problem, on YouTube only
Random avatar
arczangel
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat Jul 06 2019 19:38


Youtube Plugin (Failed to Decode Video)

Postby Ubiquinon » Sat Jul 13 2019 16:00

Hi,

that worked for me:

http://volumio.local/DEV/
or
IP-Adress/DEV/
-> SSH enable

Start Putty
Enter IP Adress - console opens, enter login data of volumio (default: volumio/volumio)

1. step:
cd data/plugins/music_service/youtube

2. step
npm i fent/node-ytdl-core

3. step
nano package.json

4. step, change following line:
"ytdl-core": "github:fent/node-ytl-core"
in
"ytdl-core": "^0.29.2"
Strg+X -> Exit, Save

5. step
npm install

Reboot Volumio

worked fine for me
Random avatar
Ubiquinon
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Sat Jul 13 2019 15:58


Re: Youtube Plugin (Failed to Decode Video)

Postby burghy » Mon Jul 22 2019 16:21

Ok. But this is a nerd Fix. Please update a plugin for a neebie

Inviato dal mio SM-A600FN utilizzando Tapatalk
Random avatar
burghy
Sunday DIYer
Sunday DIYer
 
Posts: 24
Joined: Wed Feb 14 2018 11:59


Youtube Plugin (Failed to Decode Video)

Postby arczangel » Mon Jul 29 2019 15:29

Still cant' figure out this problem, followed the putty way, but when i encode command cd.... the reply is no such directory exist.

any easy way to fix this?
Random avatar
arczangel
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat Jul 06 2019 19:38


Youtube Plugin (Failed to Decode Video)

Postby Riccisax » Thu Aug 01 2019 05:27

Yes, same problem for me. Can anyone please help those of us that are simply using the app plugin feature? I’m just a simpleton here...no knowledge of Linux language or how to putty.
Thanks
Random avatar
Riccisax
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Thu Sep 13 2018 16:45


Youtube Plugin (Failed to Decode Video)

Postby aseg » Fri Aug 02 2019 11:34

arczangel wrote:Still cant' figure out this problem, followed the putty way, but when i encode command cd.... the reply is no such directory exist.

any easy way to fix this?


Yes !
cd /data/plugins/music_service/youtube
NOT
cd data/plugins/music_service/youtube
...
Random avatar
aseg
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Fri Oct 19 2018 20:02

Next

Return to Bug reports

Who is online

Users browsing this forum: No registered users and 0 guests