YouTube plugin doesn't work anymore (2.378)

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

YouTube plugin doesn't work anymore (2.378)

Postby ginsa » Tue Mar 20 2018 22:21

Hi, after the last upgrade to 2.378 version, when I select YouTube the following 3 messages appear:
1) ! Browse error - An error occurred while browsing the folder (in red, but what folder ?)
2) Volumio has no permissions - Grant Volumio access to your TouTube account to access your playlist (in blue)
3) YouTube - Fetching data from Youtube. This may take some time (in blue)

I put a string in the search box and the I received the last message again.
I waited, but nothing happened ... I tried to update the plugin and to re-enable it, without results.
How can I authorize the access ? Before I didn't do anything and all worked very well.
Or the problem is another?

Thanks.
Random avatar
ginsa
Sunday DIYer
Sunday DIYer
 
Posts: 20
Joined: Fri May 19 2017 11:50

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


YouTube plugin doesn't work anymore (2.378)

Postby ginsa » Thu Mar 22 2018 08:55

I noticed that in the page Installed Pluging (Setting) there is an item:
Accounting Setting
- Please grant Volumio read-only access to your YouTube account. Enter this code on https://www.google.com/device:
- Code: NVJY-GJNV (auto-setted)

This code may cause the error?

None have this problem? Or none use the YouTube plugin?
Random avatar
ginsa
Sunday DIYer
Sunday DIYer
 
Posts: 20
Joined: Fri May 19 2017 11:50


YouTube plugin doesn't work anymore (2.378)

Postby ginsa » Fri Mar 23 2018 23:09

Since I received too many answers and advice... so I tried to do it myself. ;)
1. I disabled the plugin
2. I enabled it again and the displayed code in the Account Setting changed
3. from the web interface I clicked on the link: https://www.google.com/device (without steps 1 & 2 I got "Code error")
4. I entered the new displayed code and authorized the device on my Google account

Now it finds and plays music and does not return the initial " Browse error " anymore.
But I don't remember doing this in the past when I upgraded the system to a new version.
Random avatar
ginsa
Sunday DIYer
Sunday DIYer
 
Posts: 20
Joined: Fri May 19 2017 11:50


YouTube plugin doesn't work anymore (2.378)

Postby Josh2000 » Sat Mar 24 2018 13:46

Hi all,

It seems the code has to be really "fresh" to be accepted by Google / Youtube.
This is the reaseon why one has to disable/enable the plugin to get a new one.

Would be interesting for how long one can wait to register it until the "wrong code. please retry" message appears when trying to register the device.

I think this - and also the URL https://www.google.com/device should be mentioned somewhere in the plugin.

- Josef
User avatar
Josh2000
Audiophile
Audiophile
 
Posts: 176
Joined: Mon Oct 17 2016 16:43


YouTube plugin doesn't work anymore (2.378)

Postby muhackl » Wed Jan 23 2019 19:12

Hi,
I'm experiencing the following with Version 2.526 in the latest Chrome-Browser on Mac OS X
- Installing plugin Youtube Playback
- Activating Youtube Playback
- Entering settings
- Copying the code
- Log in to google
- Entering www.google.com/device
- Pasting the code
- Following the steps granting permission to Volumio Youtube connection
- Last step is telling me, the connection has been successfully established
- When entering https://myaccount.google.com/permissions there is no Volumio Youtube visible
- The plugin does not work and gives error messages "volumio hs no permissions"

Uninstalling and deactivating/reactivating the plugin, entering the newly generated code to my google account does not help.
How can I make it work?

Many thanks and best regards
Muhackl
Random avatar
muhackl
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Mon Oct 26 2015 22:27


YouTube plugin doesn't work anymore (2.378)

Postby twinterfinder » Thu Jan 24 2019 14:39

Had the same issue. Reset and reinstalled the Volumio. Problem solved.
Good luck!

muhackl wrote:Hi,
I'm experiencing the following with Version 2.526 in the latest Chrome-Browser on Mac OS X
- Installing plugin Youtube Playback
..
..
Uninstalling and deactivating/reactivating the plugin, entering the newly generated code to my google account does not help.
How can I make it work?

Many thanks and best regards
Muhackl
User avatar
twinterfinder
Sunday DIYer
Sunday DIYer
 
Posts: 16
Joined: Thu Jul 26 2018 13:40


YouTube plugin doesn't work anymore (2.378)

Postby danbeaver » Thu Apr 25 2019 20:23

I used an older version of Volumio and as of April 2019, there has been a change in the way Youtube handles these requests regardless of version used, what you do to login and register your device
Random avatar
danbeaver
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Thu Apr 25 2019 20:19


YouTube plugin doesn't work anymore (2.378)

Postby TonyK » Fri Apr 26 2019 08:29

I am unable to activate the plugin either... who can actually fix this?
Random avatar
TonyK
Fresh off the boat
Fresh off the boat
 
Posts: 8
Joined: Wed Apr 17 2019 12:40


YouTube plugin doesn't work anymore (2.378)

Postby TonyK » Mon May 27 2019 21:06

Ok, got it working...this is the sequence of events needed apparently

- uninstall current version of plugin (not sure if needed)

- reinstall youtube plugin

- activate in 'active plugins'

- goto settings of the Youtube plugin add the code to google's url as in description (browser)

- goto Volumio home youtube search, find out not working

- go back to plugins and select settings Youtube plugin

- you will now get the message that access is granted...

enjoy!!

(Btw Volumio, this plugin and Netsky rule! ;) )
Random avatar
TonyK
Fresh off the boat
Fresh off the boat
 
Posts: 8
Joined: Wed Apr 17 2019 12:40


YouTube plugin doesn't work anymore (2.378)

Postby Zathras » Fri Nov 08 2019 20:46

Thank you this just worked for me :)


TonyK wrote:Ok, got it working...this is the sequence of events needed apparently

- uninstall current version of plugin (not sure if needed)

- reinstall youtube plugin

- activate in 'active plugins'

- goto settings of the Youtube plugin add the code to google's url as in description (browser)

- goto Volumio home youtube search, find out not working

- go back to plugins and select settings Youtube plugin

- you will now get the message that access is granted...

enjoy!!

(Btw Volumio, this plugin and Netsky rule! ;) )
Random avatar
Zathras
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Thu Nov 07 2019 19:50


Return to Help

Who is online

Users browsing this forum: No registered users and 10 guests