Wolfson Audio card with Volumio

Volumio portings supported by community members

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Wolfson Audio card with Volumio

Postby debennett2 » Tue May 05 2015 12:57

Can someone provide an image that includes these drivers for the latest Volumio RP? I'd do this myself, however, foloowing the directions at https://www.bostonenginerd.com/posts/getting-the-wolfson-audio-card-working-with-volumio/ is not possible as I have no linux box to move from files around in. Please?
Random avatar
debennett2
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Thu Apr 10 2014 11:11

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Wolfson Audio card with Volumio

Postby Pippo » Fri Jul 31 2015 09:52

Nobody? At least somebody could provide a step by step insruction of
https://www.bostonenginerd.com/posts/ge ... h-volumio/
for noobs like us who are not familiar with linux.
Thanks!
Random avatar
Pippo
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Fri Jul 31 2015 09:45


Wolfson Audio card with Volumio

Postby beano_2278 » Mon Aug 17 2015 17:24

Ok, so firstly i'm no linux guru but after a few hours i have been able to take the latest 1.55 release of Volumio and patch in the Wolfson drivers as per this link.
https://www.bostonenginerd.com/posts/ge ... h-volumio/

And i now have a working setup, all the scripts to set the inputs and outputs are in the \home\use_case_scripts folder so you should be able to set the output you want.

I've uploaded the image to my Google drive for anyone wanting to have a play:

https://drive.google.com/file/d/0B6RHv7 ... sp=sharing

I originally put this in an 8Gb card so the image was quite large, however with a quick google i was able to truncate it down to 1.7Gb and then zip it, so fingers crossed it all works :)
Random avatar
beano_2278
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Mon Aug 17 2015 15:03


Wolfson Audio card with Volumio

Postby translux » Tue Sep 01 2015 04:16

beano_2278 wrote:Ok, so firstly i'm no linux guru but after a few hours i have been able to take the latest 1.55 release of Volumio and patch in the Wolfson drivers as per this link.
https://www.bostonenginerd.com/posts/ge ... h-volumio/

And i now have a working setup, all the scripts to set the inputs and outputs are in the \home\use_case_scripts folder so you should be able to set the output you want.

I've uploaded the image to my Google drive for anyone wanting to have a play:

https://drive.google.com/file/d/0B6RHv7 ... sp=sharing

I originally put this in an 8Gb card so the image was quite large, however with a quick google i was able to truncate it down to 1.7Gb and then zip it, so fingers crossed it all works :)


Thank you!
After much pain with Rune your preconfigured image worked great.
The only issue I had was that the bass was way to hot.
I did manually edit the /etc/mpd.conf as this had reverted due to a change. I also edited /etc/spopd.conf for Spotify.
Trouble is when I rebooted the web UI was blank.
A network scan shows the Pi on line and http service running/responding.
I can SSH using the IP and hostname but no HTTP.

I'm going to revert the two files I edited and see what happens.
I'll report back.

TL
Random avatar
translux
Fresh off the boat
Fresh off the boat
 
Posts: 9
Joined: Tue Sep 01 2015 03:54


Wolfson Audio card with Volumio

Postby translux » Tue Sep 01 2015 16:00

So the culprit was editing /etc/mpd.conf

From
Code: Select all
audio_output {

       type       "alsa"
       name       "Output"
       device    "hw:0,0"
       dop    "no"

}


to

Code: Select all
audio_output {

             type           "alsa"
             name           "Output"
             device         "hw:0,0"
             mixer_control  "HPOUT2 Digital"
             mixer_device   "hw:0"
             mixer_index    "0"
             dop    "no"}


reverting back brought the web ui back on line and I still have volume control but still have too much bass.

Any ideas?
Random avatar
translux
Fresh off the boat
Fresh off the boat
 
Posts: 9
Joined: Tue Sep 01 2015 03:54


Wolfson Audio card with Volumio

Postby translux » Wed Sep 02 2015 02:01

I feel like I'm talking to myself :D

All is working, bass still sounds too heavy. I tried the green line out and the black headphone output.
Maybe the output impedance of the Wolfson is not suitable for headphones??

Anyway hooked up to a monitor and found the problem.
The code that I copied is missing a return it should be:
Code: Select all
audio_output {

             type           "alsa"
             name           "Output"
             device         "hw:0,0"
             mixer_control  "HPOUT2 Digital"
             mixer_device   "hw:0"
             mixer_index    "0"
             dop    "no"
}
Random avatar
translux
Fresh off the boat
Fresh off the boat
 
Posts: 9
Joined: Tue Sep 01 2015 03:54


Wolfson Audio card with Volumio

Postby michelangelo » Thu Sep 03 2015 21:33

If the webui doesn't show it means that mpd is not able to start...
So something must be wrong with your configuration...
Regarding too much bass, I would surely blame the DAC... But no way to adjust it, since Volumio doesn't have an equalizer...
User avatar
michelangelo
Founder
 
Posts: 4205
Joined: Sun Dec 15 2013 23:18


Wolfson Audio card with Volumio

Postby sciguy54 » Sun Dec 27 2015 01:34

Translux

Your journey has just begun! Now if you want to add equalizer functionality to Volumio see here:

equalizer-t45-20.html

Some folks say that it is better to have bit-perfect music from Volumio and use a filter network with your speaker system. It is my experience that alsa equalization often gives better results than low quality filter components. Your opinion may differ if you can afford the very best filter components.
Random avatar
sciguy54
Sunday DIYer
Sunday DIYer
 
Posts: 26
Joined: Wed Oct 08 2014 14:28


Wolfson Audio card with Volumio

Postby keldo » Fri Mar 11 2016 07:35

Hi all.

Did anyone already tried to use the official 1.55 image for PI and to add a new kernel (with Wolfson drivers) by following this procedure ? :
wget -q -O - http://rpi.autostatic.com/autostatic.gpg.key | sudo apt-key add -
sudo wget -q -O /etc/apt/sources.list.d/autostatic-audio-raspbian.list http://rpi.autostatic.com/autostatic-au ... pbian.list
sudo apt-get update
sudo apt-get install cirrus-config
sudo reboot
Playback_to_Lineout.sh

It worked for me on a PI2 with a Cirrus Logic card.
Original info : https://www.element14.com/community/thr ... 5&tstart=0
RPi 2, Cirrus Logic DAC (Element14)
User avatar
keldo
Fresh off the boat
Fresh off the boat
 
Posts: 6
Joined: Fri Mar 04 2016 17:50


Wolfson Audio card with Volumio

Postby pronkert » Fri Jul 08 2016 21:00

If you're still interested you can follow this post: https://www.element14.com/community/message/201098/l/re-driver-fixes-and-updates-to-kernel-31816-and-405#201098
It explains how to get the Wolfson Cirrus DAC running on Volumio RC2 hotfix.
Random avatar
pronkert
Fresh off the boat
Fresh off the boat
 
Posts: 8
Joined: Wed Mar 02 2016 20:00
Location: Utrecht, Netherlands

PreviousNext

Return to Community portings

Who is online

Users browsing this forum: No registered users and 0 guests