Webradio not working (v2.586)

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Webradio not working (v2.586)

Postby Ruud » Thu Jun 13 2019 05:14

In Volumio v2.586 the webradio isn't working anymore. (I've got two Volumio-players both show the same issue)

Tried with numerous default Volumio-streams.

Logging from sudo journalctl -f when you press play.

Code: Select all
Jun 13 05:10:10 volumio-hostname volumio[792]: info: CoreCommandRouter::volumioPlay
Jun 13 05:10:10 volumio-hostname volumio[792]: UNSET VOLATILE
Jun 13 05:10:10 volumio-hostname volumio[792]: info: CoreStateMachine::play index undefined
Jun 13 05:10:10 volumio-hostname volumio[792]: info: CoreStateMachine::setConsumeUpdateService undefined
Jun 13 05:10:10 volumio-hostname volumio[792]: info: CorePlayQueue::getTrack 0
Jun 13 05:10:10 volumio-hostname volumio[792]: info: CoreStateMachine::startPlaybackTimer
Jun 13 05:10:10 volumio-hostname volumio[792]: info: CorePlayQueue::getTrack 0
Jun 13 05:10:10 volumio-hostname volumio[792]: info: [1560402610285] ControllerWebradio::clearAddPlayTrack
Jun 13 05:10:10 volumio-hostname volumio[792]: info: ControllerMpd::sendMpdCommand stop


Also a random radio station from the TuneIn plugin isn't working
Code: Select all
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreCommandRouter::volumioAddQueueItems
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::addQueueItems
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CorePlayQueue::addQueueItems
Jun 13 05:13:13 volumio-hostname volumio[792]: info: Adding Item to queue: http://opml.radiotime.com/Tune.ashx?id=s306583
Jun 13 05:13:13 volumio-hostname volumio[792]: info: Exploding uri http://opml.radiotime.com/Tune.ashx?id=s306583 in service tunein_radio
Jun 13 05:13:13 volumio-hostname volumio[792]: error: [TuneIn] Fetching details for stream: s306583
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CorePlayQueue::saveQueue
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreCommandRouter::volumioPushQueue
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::updateTrackBlock
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CorePlayQueue::getTrackBlock
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreCommandRouter::volumioPlay
Jun 13 05:13:13 volumio-hostname volumio[792]: UNSET VOLATILE
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::play index 3
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::setConsumeUpdateService undefined
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::stop
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::setConsumeUpdateService undefined
Jun 13 05:13:13 volumio-hostname volumio[792]: UNSET VOLATILE
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::play index undefined
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::setConsumeUpdateService undefined
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CorePlayQueue::getTrack 3
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CoreStateMachine::startPlaybackTimer
Jun 13 05:13:13 volumio-hostname volumio[792]: info: CorePlayQueue::getTrack 3
Jun 13 05:13:13 volumio-hostname volumio[792]: info: [1560402793196] ControllerWebradio::clearAddPlayTrack
Jun 13 05:13:13 volumio-hostname volumio[792]: info: ControllerMpd::sendMpdCommand stop
Random avatar
Ruud
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Thu Jun 13 2019 05:05

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Webradio not working (v2.586)

Postby chsims1 » Thu Jun 13 2019 06:35

v2.587 working on a RPi here, so try updating. You do release that you are using test versions here, where things change and can be broken?
New to Volumio? Please read the Quick Start Guide to get your system up and running :). FAQs? Docs?
User avatar
chsims1
Moderator
 
Posts: 1799
Joined: Sat Aug 02 2014 10:44
Location: East Yorkshire, UK


Webradio not working (v2.586)

Postby Ruud » Thu Jun 13 2019 06:38

Ah, no I didn't realise I was using a test-version.... That's why I didn't update to .587.
Random avatar
Ruud
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Thu Jun 13 2019 05:05


Webradio not working (v2.586)

Postby chsims1 » Thu Jun 13 2019 07:01

Sorry, you are correct 2.586 isn't a test version. I shouldn't type until I have had my morning coffee ;).
New to Volumio? Please read the Quick Start Guide to get your system up and running :). FAQs? Docs?
User avatar
chsims1
Moderator
 
Posts: 1799
Joined: Sat Aug 02 2014 10:44
Location: East Yorkshire, UK


Webradio not working (v2.586)

Postby Ruud » Thu Jun 13 2019 07:42

Hehe, that clears things for me. There was no mention about a test-version when updating to 2.586.

Did a factory reset and the radio is working again. :) Now let's just wait for the .587 to be general available.
Random avatar
Ruud
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Thu Jun 13 2019 05:05


Webradio not working (v2.586)

Postby chsims1 » Fri Jun 14 2019 18:12

Glad you've sorted it Ruud. I've just got round to factory resetting one of my RPis and updating to 2.586 to check what happens. As you say there is no problem with radio streaming by this route, but it doesn't explain what the original problem was. OTA updates are great and convenient when they work (most of the time to be fair), but it can be complex & lead to niggling problems such as this.
New to Volumio? Please read the Quick Start Guide to get your system up and running :). FAQs? Docs?
User avatar
chsims1
Moderator
 
Posts: 1799
Joined: Sat Aug 02 2014 10:44
Location: East Yorkshire, UK


Return to Help

Who is online

Users browsing this forum: No registered users and 0 guests