Volumio2 and brutefir...

Discuss, contribute and orient Volumio development!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Volumio2 and brutefir...

Postby Solveit » Thu Oct 10 2019 11:45

Ok I think RPI 3B as i have, not 3B+, you not getting it 100% with USB out.
But!
Separate the power opened the Khadas DAC up!
Random avatar
Solveit
Serious Listener
Serious Listener
 
Posts: 63
Joined: Sun Sep 29 2019 18:49

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio2 and brutefir...

Postby Solveit » Fri Oct 11 2019 12:03

I changed wifi spot to an better with 72Mbit/s and now its working without cracks.
Strange that its so picky, 28Mbit/s just cracking every 5 second.
Random avatar
Solveit
Serious Listener
Serious Listener
 
Posts: 63
Joined: Sun Sep 29 2019 18:49


Volumio2 and brutefir...

Postby Solveit » Wed Oct 16 2019 22:39

Have Raspberry Zero enough cpu power to run Brutefir?
Random avatar
Solveit
Serious Listener
Serious Listener
 
Posts: 63
Joined: Sun Sep 29 2019 18:49


Volumio2 and brutefir...

Postby balbuze » Thu Oct 17 2019 07:35

I didn't test this configuration. But I'm afraid you are going to experience glitches, and more problems with usb Dac. But once again, I didn't tested it.
User avatar
balbuze
Moderator
 
Posts: 1760
Joined: Thu May 08 2014 08:42
Location: Isère France


Volumio2 and brutefir...

Postby Solveit » Tue Oct 29 2019 12:10

After reboot output format jumps to SPECIAL which dont work for me so have to change it to HW-Detected-S32LE.
Latest update 2.659
Random avatar
Solveit
Serious Listener
Serious Listener
 
Posts: 63
Joined: Sun Sep 29 2019 18:49


Volumio2 and brutefir...

Postby balbuze » Tue Oct 29 2019 17:04

@Solveit : does it occurs each reboot? Or after enabling the plugin? What is your DAC? Are HW-Detected value OK ?
TY
User avatar
balbuze
Moderator
 
Posts: 1760
Joined: Thu May 08 2014 08:42
Location: Isère France


Volumio2 and brutefir...

Postby Solveit » Tue Oct 29 2019 17:21

It happens every reboot but Hw works for me.
Khadas Tone DAC.
Random avatar
Solveit
Serious Listener
Serious Listener
 
Posts: 63
Joined: Sun Sep 29 2019 18:49


Volumio2 and brutefir...

Postby balbuze » Tue Oct 29 2019 17:48

what are hw-detected values? Is your setting overwritten each boot?
Btw, I made some changes with last version, it may improve glitches with usb dac and RPI3
User avatar
balbuze
Moderator
 
Posts: 1760
Joined: Thu May 08 2014 08:42
Location: Isère France


Volumio2 and brutefir...

Postby Solveit » Tue Oct 29 2019 18:21

Dont know what or where too find hw-detected values?

Maybe a little improvement of the glitches.



Code: Select all
volumio volumio[4440]: BruteFIR v1.0m (November 2013)                                (c) Anders Torger
Oct 29 18:28:41 volumio volumio[4440]: Internal resolution is 64 bit floating point.
Oct 29 18:28:41 volumio volumio[4440]: Creating 4 FFTW plans of size 16384...finished.
Oct 29 18:28:41 volumio volumio[4440]: Loading 16 coefficient sets...finished.
Oct 29 18:28:41 volumio volumio[4440]: Realtime priorities are min = 2, usermax = 1, mid = 3 and max = 4.
Oct 29 18:28:41 volumio volumio[4440]: Warning: no support for clock cycle counter on this platform.
Oct 29 18:28:41 volumio volumio[4440]: Timers for benchmarking may be unreliable.
Oct 29 18:28:41 volumio volumio[4440]: Filters in process 0: 0 2
Oct 29 18:28:41 volumio volumio[4440]: Filters in process 1: 1 3
Oct 29 18:28:41 volumio volumio[4440]: ALSA I/O: Could not set audio input parameters for "hw:Loopback,1":
Oct 29 18:28:41 volumio volumio[4440]: Failed to set sample format to S32_LE: Invalid argument.
Oct 29 18:28:41 volumio volumio[4440]: Failed to init input device.
Oct 29 18:28:41 volumio volumio[4440]: Failed to initialise digital audio interfaces.
Oct 29 18:28:41 volumio systemd[1]: brutefir.service: main process exited, code=exited, status=1/FAILURE
Oct 29 18:28:41 volumio systemd[1]: Unit brutefir.service entered failed state.
Oct 29 18:28:42 volumio systemd[1]: brutefir.service holdoff time over, scheduling restart.
Oct 29 18:28:42 volumio systemd[1]: Stopping brutefir Daemon...
Oct 29 18:28:42 volumio systemd[1]: Starting brutefir Daemon...
Oct 29 18:28:42 volumio systemd[1]: brutefir.service start request repeated too quickly, refusing to start.
Oct 29 18:28:42 volumio systemd[1]: Failed to start brutefir Daemon.
Oct 29 18:28:42 volumio systemd[1]: Unit brutefir.service entered failed state.
Last edited by Solveit on Tue Oct 29 2019 18:29, edited 1 time in total.
Random avatar
Solveit
Serious Listener
Serious Listener
 
Posts: 63
Joined: Sun Sep 29 2019 18:49


Volumio2 and brutefir...

Postby krunok » Tue Oct 29 2019 18:29

Solveit wrote:Have Raspberry Zero enough cpu power to run Brutefir?


You are having glitches because of the shared architecture between networking and USB port on 3B and 3B+. You can either upgrade to RPI 4 or use I2S DAC instead of USB DAC.
Random avatar
krunok
Sunday DIYer
Sunday DIYer
 
Posts: 38
Joined: Mon Apr 30 2018 19:19

PreviousNext

Return to Development talks

Who is online

Users browsing this forum: No registered users and 0 guests