Volumio for Raspberry PI 3b+

Here you can find all important communications from Volumio's staff

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Re: Volumio for Raspberry PI 3b+

Postby bazylimarek » Sun Mar 25 2018 03:36

I've just flashed volumio-2.382 on Raspberry Pi 2. My setup consist of Raspberry Pi, Witty Pi2 and IqAudio Pi-DAC Pro.
Now I’m listening to music from two USB drives: one directly connected to my Pi, another to my router. In both cases everything works as fine as it was with volumio-2.378.
Regards.
Random avatar
bazylimarek
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Sun Sep 03 2017 22:38

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio for Raspberry PI 3b+

Postby skikirkwood » Sun Mar 25 2018 17:33

I'm running 2.382 on a new Raspberry Pi 3 B+ and everything is working perfectly. I just installed 2.388 on an older Pi 3 (not B+) and it works great too but I'm not seeing artwork from Spotify.

Playing the same album on both Pi's I can see from the 2.382 log the correct URL for the Spotify artwork:

2018-03-25T03:12:03.689Z - info: {"uri":"spotify:track:5SrzbFoptS7ngE2jN6tNqc","service":"spop",...,"albumart":"https://i.scdn.co/image/2d2070d30ecc35db4f18e0471ea3fc694d1bdb4f",...}

On the 2.3888 system it is not using the URL returned from the Spotify Web API call:

2018-03-25T17:17:57.902Z - info: {"uri":"spotify:track:4W0HcgAUL1B4oc7bSUQED4","service":"spop",..."albumart":"/albumart?web=tyDi%2C%20Christopher%20Tin%2C%20Dia%20Frampton/COLLIDE/large&path=",..."trackType":"spotify"}

I don't see anything in the Spotify plugin that changed recently regarding album art.
Last edited by skikirkwood on Sun Mar 25 2018 21:25, edited 1 time in total.
Volumio 2 on Raspberry Pi 3 B+, Schiit Modi 2 Multibit DAC, Volumio 2 on Raspberry Pi 3, IQAudio Pi-DAC+, Schiit Freya preamp, Bryston 3b power amp, B&W 803 speakers
User avatar
skikirkwood
Objectivist
Objectivist
 
Posts: 265
Joined: Thu Jan 08 2015 17:16
Location: Los Altos Hills, California


Re: Volumio for Raspberry PI 3b+

Postby joao.tira » Sun Mar 25 2018 19:54

this Raspberry PI 3b+ dont work with this image ask the login and pass and stop...... any help please?
Random avatar
joao.tira
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Sun Mar 25 2018 18:06


Re: Volumio for Raspberry PI 3b+

Postby michelangelo » Mon Mar 26 2018 19:36

Version 2.389 released, it officially provides PI 3B+ support
User avatar
michelangelo
Founder
 
Posts: 4145
Joined: Sun Dec 15 2013 23:18


Re: Volumio for Raspberry PI 3b+

Postby AndrewHeard » Wed Mar 28 2018 00:29

Upgrade from 387 to 389 fixed slow wifi/ hotspot bug when wifi not available @ boot. Thanks. Although if wifi not available until after volumio boots there is no attempt to connect or reconnect unless I manually pause>play.
Last edited by AndrewHeard on Wed Mar 28 2018 21:58, edited 1 time in total.
Random avatar
AndrewHeard
Serious Listener
Serious Listener
 
Posts: 71
Joined: Tue Dec 19 2017 05:15


Re: Volumio for Raspberry PI 3b+

Postby dlmulder » Wed Mar 28 2018 04:09

I installed 2.389 on a 3B+ and got static/white noise with my Allo setup (Kali/Piano2.1). Searching around I found a hint that the 4.14 kernel might have I2S problems with 24-bit audio, so I enabled Audio Resampling to 32-bit depth, and now I get music. I haven't spent much time on it, but 5gHz wifi works, and streaming from a NAS over wifi works. I do get the low-voltage warning repeatedly, even with the 3A wall wart from Allo powering the Pi through the header pins.

A question: I initially tried to set up the Pi separate from the Kali, etc, and the Pi seemed to hang or be very slow most of the time, but once I plugged everything together it works well. Is that expected? I'm just curious, it's not a problem.
Random avatar
dlmulder
Fresh off the boat
Fresh off the boat
 
Posts: 7
Joined: Wed Mar 28 2018 03:55


Volumio for Raspberry PI 3b+

Postby judydudi » Mon Jul 23 2018 20:09

i had problems with the PI 3B+ and Kali (with mamboberry HD+) and v.2.413
music from nas (mp3, etc. ) start and stops. sometimes device hangs completly.
updating to the dev version 2.442 and turning upsampling to 32 bit target seem to be stable.

UPDATE: volume goes every time back to 0 after restart! preset does not work (software controled volume)
User avatar
judydudi
Objectivist
Objectivist
 
Posts: 228
Joined: Sun Sep 25 2016 16:33
Location: Hamburg

Previous

Return to Staff comunications

Who is online

Users browsing this forum: No registered users and 0 guests
cron