Volumio for Raspberry PI model B+

Discuss, contribute and orient Volumio development!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Volumio for Raspberry PI model B+

Postby arginine » Tue Oct 14 2014 12:37

hello,

while cloning your code (git clone git@github.com:jotak/Volumio-UI.git /var/www) I end up with errors :

"Cloning into '/var/www'...
ERROR: Repository not found.
fatal: The remote end hung up unexpectedly"

does your github still alive ?

ps: I did created a github account, make a ras key, check the connexion using ssh -T git@github.com and it was ok (i.e., I don t think that I did a "mistake" in the setup).
Random avatar
arginine
Sunday DIYer
Sunday DIYer
 
Posts: 49
Joined: Tue Mar 25 2014 18:33

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio for Raspberry PI model B+

Postby arginine » Tue Oct 14 2014 14:02

Hi,

I've possibly found out a minor "bug" in the library tab for the "advanced options" :
- I wanted to add a NAS mount (NFS) and I selected CIFS/SMB by mistake ... (obviously it was not working). I looked at the advanced options and I see a long string for the "advanced options" (ro,dir_mode=0777,file_mode=0777)
- I changed the NAS mount to NFS and the advanced options were still "ro,dir_mode=0777,file_mode=0777"
- Updating this options to the default(?) NFS "advanced options" : ro,native, all was fine

does the advanced options are not updated with their default values while changing from NFS to CIFS/SMB ?
Random avatar
arginine
Sunday DIYer
Sunday DIYer
 
Posts: 49
Joined: Tue Mar 25 2014 18:33


Volumio for Raspberry PI model B+

Postby joda2 » Tue Oct 14 2014 15:25

if you found a bug, please post it here: http://volumio.org/forum/enabling-disabling-the-library-t1712.html

arginine wrote:does your github still alive ?


Its not my code (i am not a programmer), if you have questions you should ask jotak.
Volumio 1.5 supports Spotify 8-)

Changelog: http://goo.gl/rkjrqe

if you found a grammatical error you can keep it for yourselve
User avatar
joda2
Moderator
 
Posts: 290
Joined: Mon May 12 2014 21:17
Location: Germany


Volumio for Raspberry PI model B+

Postby michelangelo » Tue Oct 14 2014 15:34

arginine wrote:hello,

while cloning your code (git clone git@github.com:jotak/Volumio-UI.git /var/www) I end up with errors :

"Cloning into '/var/www'...
ERROR: Repository not found.
fatal: The remote end hung up unexpectedly"

does your github still alive ?

ps: I did created a github account, make a ras key, check the connexion using ssh -T git@github.com and it was ok (i.e., I don t think that I did a "mistake" in the setup).


The github account you're referring is Jotak's one... Official Volumio one is

https://github.com/volumio/Volumio-WebUI

However cloning it will probably break your system. We are reworking lots of stuff.. A bit of patience and you'll see everything in its place with the new 1.5 version...
User avatar
michelangelo
Founder
 
Posts: 4236
Joined: Sun Dec 15 2013 23:18


Volumio for Raspberry PI model B+

Postby CatmanV2 » Thu Oct 16 2014 07:28

Hiya

All fixed :)

C
Last edited by CatmanV2 on Thu Oct 16 2014 18:00, edited 1 time in total.
Random avatar
CatmanV2
Sunday DIYer
Sunday DIYer
 
Posts: 15
Joined: Thu Oct 16 2014 06:41


Volumio for Raspberry PI model B+

Postby CatmanV2 » Thu Oct 16 2014 17:48

As above

C
Random avatar
CatmanV2
Sunday DIYer
Sunday DIYer
 
Posts: 15
Joined: Thu Oct 16 2014 06:41


Volumio for Raspberry PI model B+

Postby tripwr1964 » Sat Oct 18 2014 14:51

got my dac+ up and going with v1.41 and some code help from this forum last night.
(i am not a programer... so this took focus and no drinking on my part. lol)

all 16/44.1 seemed to be working and playing. however anything >16/44.1 was not. it would play at 2x,-3x, the normal speed.

this morning i started playing with the playback resampling and now i get nothing. disabled it, nothing. reset to defaults, still nothing.

the webui is working and green light on dac.... what am i missing?
User avatar
tripwr1964
Sunday DIYer
Sunday DIYer
 
Posts: 21
Joined: Thu Oct 16 2014 16:48


Volumio for Raspberry PI model B+

Postby tripwr1964 » Sat Oct 18 2014 18:59

found my problem.
had to go back in and change the mixer_control from "DSP Program" back to "Playback Digital".

not sure how changing the playback resampling in the webui changed the above...

back to working again (only 16/44.1.)
User avatar
tripwr1964
Sunday DIYer
Sunday DIYer
 
Posts: 21
Joined: Thu Oct 16 2014 16:48


Volumio for Raspberry PI model B+

Postby clee » Tue Oct 21 2014 18:45

We got our Pi Dac+ HAT and followed the instructions from this forum and from Gordon. He sends a PDF with instructions. My daughter did the mechanical parts, putting the HAT on the raspberry pi B+ and putting in the SD card. It was easy with me offering as an extra hand when needed to holding things still.

I did the software side with volumio 1.41 beta. The only issue we had was when we tried to test it out before plugging it in the network, it will not drive the 1650x1050 monitor properly. The text appears, but it flashes constantly. Other versions work with video (raspberian, even volumio 1.40). This did not affect the remote interface though.

Plugged in the ethercable and the audio jacks and it worked beautifully both via airplay from the iphone and via bubble on android. I can get it to play mp3, ogg, and flac from CD as well as the high fidelity flacs sampled at 96kHz/24bit and 196kHz/24bit samples from 2L

They all sound great.

Many thanks to Michelangelo and all the contributors and to Gordon at IQaudIO
-Chris
Random avatar
clee
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Thu Oct 16 2014 14:24

Previous

Return to Development talks

Who is online

Users browsing this forum: No registered users and 0 guests