Volumio for Raspberry PI model B+

Discuss, contribute and orient Volumio development!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Volumio for Raspberry PI model B+

Postby zespre » Tue Sep 02 2014 22:53

Thanks Plasma25!

My Rasberry Pi with HiFiBerry DAC+ is working too :) I've tried to make it work for a few days, first with OpenELEC, then Raspbmc, Raspbian with no success. I've seen led DAC+ light on few times, but no sound yet, till today :)

OpenELEC - thanks to develepers and chat on IRC i've loaded modules, but it hangs when you select DAC+ (ALSA) on the list in XBMC.
Raspbian - there was a problem with XBMC in full hd so i've let it go, the led was also on, but no way to test it (no ability to configure it)

If you have any other successes or just want to share (I can write exactly what i have tried) I would be glad to write to you. My goal is to make XBMC work, best on OpenELEC 'cause it's easiest to run and configure. I've also some issues with wifi dongle, which i have 'steal' from my Xtreamer, it works on OpenELEC, Raspbian, on Volumio not yet ;)
Random avatar
zespre
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Tue Sep 02 2014 17:29

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio for Raspberry PI model B+

Postby bower » Thu Sep 04 2014 14:00

Hi Guys,

I've also have a model B+, and put the 1.41 version on the SD card. During the boot process it also stops at transientlog permission denied, and the GUI does not start. If I understand well, that this version contains the update that needs for the model B+? What else can I check?
I have a 2GB SD card. I think it shouldn't be a problem.

Thanks,

Gábor
Random avatar
bower
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Thu Sep 04 2014 13:52


Volumio for Raspberry PI model B+

Postby michelangelo » Thu Sep 04 2014 14:35

bower wrote:Hi Guys,

I've also have a model B+, and put the 1.41 version on the SD card. During the boot process it also stops at transientlog permission denied, and the GUI does not start. If I understand well, that this version contains the update that needs for the model B+? What else can I check?
I have a 2GB SD card. I think it shouldn't be a problem.

Thanks,

Gábor


What you mean with GUI does not start? You access the GUI via a browser not via monitor...
User avatar
michelangelo
Founder
 
Posts: 4377
Joined: Sun Dec 15 2013 23:18


Volumio for Raspberry PI model B+

Postby oaksboard » Thu Sep 04 2014 19:41

hello everybody,

using version 1.41 and following the instructions above i was able to get my raspi b+ and hifiberry digi+ to work.

but i'm having problems with playback of audio content with sampling rates above 48k. i have some 24/96 flac files that will not play back correctly.
playback seems to be faster than normal and with a lot of noise and clicks.

the same does happen with an usb dac i normally use on a dreamplug box (where it works flawlessly). everything below 96k works perfectly.

bye,
oskar
Random avatar
oaksboard
Sunday DIYer
Sunday DIYer
 
Posts: 13
Joined: Thu Sep 04 2014 19:32


Volumio for Raspberry PI model B+

Postby bower » Fri Sep 05 2014 07:07

What you mean with GUI does not start? You access the GUI via a browser not via monitor...


Thanks, it the meantime I've realized that there is no traditional GUI on the PI :-(
Now it has started to play music through my DacMagic, therefore it's OK now.

Just a few things, I'm trying to check this once again, but:
On the web interface I was not able to play music on the USB drive. Library seems to be empty, after pressing update library it is the same.
When using Sound@home for Volumio on android, it shows the USB content, and plays correctly.

Thank you for your answer, and your work providing this distro!!!
Random avatar
bower
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Thu Sep 04 2014 13:52


Volumio for Raspberry PI model B+

Postby boros2me » Mon Sep 08 2014 13:35

oaksboard wrote:hello everybody,

using version 1.41 and following the instructions above i was able to get my raspi b+ and hifiberry digi+ to work.

but i'm having problems with playback of audio content with sampling rates above 48k. i have some 24/96 flac files that will not play back correctly.
playback seems to be faster than normal and with a lot of noise and clicks.

the same does happen with an usb dac i normally use on a dreamplug box (where it works flawlessly). everything below 96k works perfectly.

bye,
oskar


Hey oskar,

I have the same issue with some flacs. Can you try if mplayer plays it any better? That works for me.
This is how Get Lucky sounds for me with Hifiberry DAC+: https://soundcloud.com/borostomi/dac-issue

-Tamas
Random avatar
boros2me
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Mon Sep 08 2014 13:31


Volumio for Raspberry PI model B+

Postby oaksboard » Mon Sep 08 2014 22:11

hello tamas,

i can confirm that files play back perfectly with mplayer. so this seems to be a mpd issue?
files also do play back fine if i add
Code: Select all
format "48000:24:2"
to the output section of mpd.conf (but that is not an option ;) )

updated to new firmware (Linux volumio 3.12.28+ #709) today, but no change.

it seems as if files play back about 2x to 3x faster than normal, with a lot of clicks and noise, exactly like the one you posted.

bye,
oskar
Random avatar
oaksboard
Sunday DIYer
Sunday DIYer
 
Posts: 13
Joined: Thu Sep 04 2014 19:32


Volumio for Raspberry PI model B+

Postby rjeeves33 » Thu Sep 11 2014 05:27

Hi Everyone

I followed the instructions on page 2 to get the DAC+ working with pi b+. Absolutely awesome, Thanks so much for posting. I followed the instructions to the letter and upon reboot my RCA connections were sending audio to my amplifier. Sweet

I'm just wondering how you guys finding the sound quality though. I don't have golden ears but have the pi/hifiberry dac+ connected to my Yamaha AS 500 & Tannoy monitors and the sound quality is almost unbearable. Sibilance is earsplitting and all high frequencies sound incredibly artificial with some female vocals almost sounding robotic. Based on the praise I have seen both Volumio & the hifiberry Dac receive I wonder if what I am hearing is caused somehow by a driver/setup issue.

Thanks for any feedback
Random avatar
rjeeves33
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Thu Sep 11 2014 05:19


Volumio for Raspberry PI model B+

Postby Mandretti » Thu Sep 11 2014 12:10

I've got the same issues as mentioned above.
Playing hi-res flacs at double / triple speed and poor sound quality...

It must be a kerner / driver problem...

regards Mandretti
Random avatar
Mandretti
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Thu Sep 11 2014 12:04


Volumio for Raspberry PI model B+

Postby oaksboard » Fri Sep 12 2014 12:38

status update: i have tried to go back to the "stock" version of mpd (0.16.7-2+b1) on wheezy with no success. the issue is still there.

something else i could try?

bye,
oskar
Random avatar
oaksboard
Sunday DIYer
Sunday DIYer
 
Posts: 13
Joined: Thu Sep 04 2014 19:32

PreviousNext

Return to Development talks

Who is online

Users browsing this forum: No registered users and 7 guests