Volumio for Raspberry PI model B+

Discuss, contribute and orient Volumio development!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Volumio for Raspberry PI model B+

Postby MartinT » Tue Aug 12 2014 11:56

I can only say that changing between USB DAC output and the audio jack requires a reboot. Try removing any USB connection and reboot?
User avatar
MartinT
Serious Listener
Serious Listener
 
Posts: 58
Joined: Wed Jul 30 2014 12:53

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio for Raspberry PI model B+

Postby epz » Wed Aug 13 2014 11:06

Dear Michelangelo,

I am very interested to test volumio on my new pi B+, where as I have no raspb Pi before, but having problems using volumio 1.41. Thanks a lot for your efforts to the audio community!

I downloaded 1.41 and is it running till transientlog, where I get a notice failed at ..... run player : no such file or directory.

I did also the update for drivers (usb/internet) and also the chmod 777 /ect/hostname and chmod 777 /ect/hosts,

but each time it fails at transientlog permission denied. The internet is working, while the updates where installed.

Any idea to fix this issue?

best Paul
Random avatar
epz
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Wed Aug 13 2014 10:56


Volumio for Raspberry PI model B+

Postby zCRiSiSz » Thu Aug 14 2014 14:19

zCRiSiSz wrote:Hi,

Bit of a n00b with a bit of a n00b question.

I have my RPi B+ up and running; it has cataloged the music on my NAS drive and I am able to play music via the HDMI cable.

I need to be able to play music via the 3.5mm jack plug.

I have checked the ALSA config using 'amixer' to check the settings - all things point to the 3.5mm jack being enabled however no sound is coming out.

Can anyone help?

Thanks in advance.


Turns out I 'may' have screwed the config; re-flashed card and all now working as it should - just need to try and get WiFi working now :)
Random avatar
zCRiSiSz
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Mon Aug 11 2014 12:35


Volumio for Raspberry PI model B+

Postby orion12370 » Fri Aug 15 2014 19:39

Raspberry B +, how to get to DAC I2s?
Random avatar
orion12370
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Fri Aug 15 2014 19:32


Volumio for Raspberry PI model B+

Postby IRoN » Fri Aug 29 2014 12:07

orion12370 wrote:Raspberry B +, how to get to DAC I2s?


Cannot get it to work too ...

is this patch needed ? :

http://www.tjaekel.com/T-DAC/files/RPi-Bplus_guideline.pdf

I get this error : Job Failed background worker is busy.

And no sound ...

Please help ;)
User avatar
IRoN
Serious Listener
Serious Listener
 
Posts: 93
Joined: Mon Mar 17 2014 14:49


Volumio for Raspberry PI model B+

Postby Chichi » Sat Aug 30 2014 09:37

IRoN wrote:
orion12370 wrote:Raspberry B +, how to get to DAC I2s?


Cannot get it to work too ...

is this patch needed ? :

http://www.tjaekel.com/T-DAC/files/RPi-Bplus_guideline.pdf

I get this error : Job Failed background worker is busy.

And no sound ...

Please help ;)


Hi,

I have the exact same problem with the new HiFiBerry DAC+.

Does anyone knows how to fix this?

Thanks !
Random avatar
Chichi
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Sat Aug 30 2014 09:34


Volumio for Raspberry PI model B+

Postby Plasma25 » Sat Aug 30 2014 16:18

Hi!

Same situation here.
I've a Raspi B+ with Hifiberry DAC+ hooked up on it.
As soon as I try to activate the I2S driver for the HifiBerry I get the Errormessage:
"Job Failed. Background worker is busy."

Also strange: On every 2nd or 3rd reboot of the Raspi, the Audio Output device on Playback Page changes from "ALSA" to "sndrpihifiberry" without intervention. As soon as this happens, the DropDown Menu for the Output Device has only one device to choose from. So, one time I could only select "ALSA" and one time "sndrpihifiberry"

Any idea?
If you need some logs, or if you tell how to enable debugging, I'll try to send as much info as possible to help sorting this out.

Best regards,
Andi
May the routingtable be with you!
User avatar
Plasma25
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat Aug 30 2014 16:01
Location: Austria


Volumio for Raspberry PI model B+

Postby Plasma25 » Mon Sep 01 2014 06:51

Hi,

got some updates, but still no sound:

What I did until now:
    sudo apt-get update
    sudo apt-get upgrade
    sudo reboot
After reboot:
    sudo apt-get install binutils
    sudo rpi-update
    sudo reboot
Change config in "/etc/modules" to
    snd_soc_bcm2708
    bcm2708_dmaengine
    snd_soc_hifiberry_dacplus
Rebooted again but still no audio.

Can someone tell me where to find config files for Volumio or is there a page where I can find some documention to get on tinkering ;-)

Best regards,
Andi
May the routingtable be with you!
User avatar
Plasma25
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat Aug 30 2014 16:01
Location: Austria


Volumio for Raspberry PI model B+

Postby zespre » Tue Sep 02 2014 17:35

Hello,

I've got 1680x1050 screen. It says the resolution is not optimal and i can't see nothing. When I've tried to boot with 1.4 version it doesn't work, of course, but i could see all booting sequence and there were no problem with LCD screen. Shouldn't it adjust to resolution of my screen?
Random avatar
zespre
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Tue Sep 02 2014 17:29


Volumio for Raspberry PI model B+

Postby Plasma25 » Tue Sep 02 2014 20:34

Hi guys!

Finally I was able to bring my Hifiberry DAC+ on my Raspberry B+ to life!

What did I do:
1.) Setup Micro SD card with Volumio 1.41 according to the well known procedure :-)
2.) Hook up PI to your Network
3.) Power on PI, let it boot up, SSH to it and login (or just start over with the procedure below if you are directly on the console)

As I personally like VI, I'll use itduring the procedures below it to edit files. Use the editor (nano,...) of your choice.;-)

4.) System Preparation:

I do not need any X on my setup so I reduced Video Memory to 8MB. Thats at least enough to display on HDMI ;-)
This step is optional and can be ignored.
Code: Select all
sudo vi /boot/config.txt

Change file content to:
Code: Select all
gpu_mem=8
hdmi_drive=2

Update installed binaries / Libraries to the latest versions.
Code: Select all
sudo apt-get update
sudo apt-get upgarde

Update process will be interupted 2 times
1st: Only some information... Just press "q" to go on.
2nd: The upgrade process wants to change a Volumio Configuration file `/etc/php5/fpm/pool.d/www.conf'. As I didn't look into the file and did not want to mess up my installation, I kept it as it was. Press N or O to keep the existing file!
Code: Select all
sudo reboot


After reboot do:
Code: Select all
sudo apt-get install binutils
sudo rpi-update
sudo reboot

The rpi-update installed kernel version 3.12.26+. With an older version it is maybe not working!

5.) Setup Config Files to recognize Hifiberry DAC+
Code: Select all
sudo vi /etc/modules

Change file content to:
Code: Select all
snd_soc_bcm2708
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_pcm5102a
snd_soc_hifiberry_dacplus

Code: Select all
sudo vi /etc/asound.conf

Change file content to:
Code: Select all
pcm.!default  {
 type hw card 0
}
ctl.!default {
 type hw card 0
}


Code: Select all
sudo reboot


After the reboot you'll notice that the little green LED on the DAC+ is on!
Hooray!! :lol:

6.) Login to Web GUI of Volumio, go to the Playback Section and change the Audio Output to sndrpihifiberry. Save the changes.

7.) Setup Config Files to allow Hifiberry DAC+ Hardware volume Control
Code: Select all
sudo vi /etc/mpd.conf

Look for code
Code: Select all
audio_output {

                 type           "alsa"
                 name           "Output"
                 device         "hw:0,0"
                 mixer_control  "DSP Program"
                 mixer_device   "hw:0"
                 mixer_index    "0"
                 dsd_usb        "yes"

}

and change it to
Code: Select all
audio_output {

                 type           "alsa"
                 name           "Output"
                 device         "hw:0,0"
                 mixer_control  "Playback Digital"
                 mixer_device   "hw:0"
                 mixer_index    "0"
                 dsd_usb        "yes"

}



Restart MPD Daemon
Code: Select all
sudo /etc/init.d/mpd restart


That's it!
Start a Webradio Stream and enjoy!

Finally Setup your Volumio as you like.

Please keep in mind that this is only a workaround to get Volumio on a Raspberry PI B+ with a Hifiberry DAC+ up and running!! :ugeek:
So changing settings in the Playback or System section of the GUI can mess up the workaround from above.
As a final solution Michelangelo has to integrate this in the GUI. Here is only a possible way to go! :D

Have fun!

PS:
Also got this strange resolution on the HDMI Interface of the PI as zespre told. My small 17" display is not able to display it correctly. So no direct console access. If I hook it up to my large display, it is working, as it is able to view the resolution.
May the routingtable be with you!
User avatar
Plasma25
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Sat Aug 30 2014 16:01
Location: Austria

PreviousNext

Return to Development talks

Who is online

Users browsing this forum: No registered users and 5 guests