Page 46 of 49

Spotify Connect

PostPosted: Mon Mar 25 2019 10:47
by ashthespy
Milbebonbon605 wrote:Hello, I try my best in English, please forgive me! I also have troubles with volumio on rpi3b
I have volumio updated to version 2.565 and volspotconnect2 0.9 (trying 0.91..)

streaming works normally Without problems many hours, but every song I start or change has a huge delay of 10 - 15 seconds before audio comes!!
Play and pause works with minimal delay when button is touched.

I hope the will be a solution soon..


Got an improvement for this issue, I think it's more pronounced on slower internet connections, but will push out a new release sometime this week that should help :-)

Spotify Connect

PostPosted: Wed Mar 27 2019 18:23
by rorygennaro
Hi,
I use volumio volumio-2.565-2019-03-12-pi and Connect2 plugin.

I haven't DAC and I use Jack through equalizer plugin.

If I connect and play from my cell it sound just once and then says payng but no sound.
If I change Audio to just Jack it works and play sound.

Thank you
Bye

Spotify Connect

PostPosted: Wed Apr 03 2019 01:08
by diggledude
Hi all.
I am seeing two different plugins for spotify on the "music services" plugin tab. One is version 1.3.5 (last updated over a year ago) and another version 0.9.1 (updated recently). Could someone explain the difference between these two?

Spotify Connect

PostPosted: Wed Apr 03 2019 08:38
by ashthespy
diggledude wrote:Hi all.
I am seeing two different plugins for spotify on the "music services" plugin tab. One is version 1.3.5 (last updated over a year ago) and another version 0.9.1 (updated recently). Could someone explain the difference between these two?


One is Spotify Connect (https://www.spotify.com/us/connect/) and the other is regular Spotify

Spotify Connect

PostPosted: Sat Apr 06 2019 23:18
by mleuba
I’m a new owner of Primo and first time Volumio user. The Spotify Connect plugins are virtually non functional. The only tracks that are available are in the What’s New folder, other folders appear to have playlists but none of them actually function, click on the playlist and nothing happens. It’s really virtually useless as is. I saw in a development thread someone has fixed Spotify Connect or provided an alternative but I don’t see it as a plugin so it’s not available to me. Unfortunate because I’m a Spotify user And wanted to stream both Spotify and my music through Volumio.

Spotify Connect

PostPosted: Sun Apr 07 2019 01:41
by yungyaw
Lately I have been having trouble using volspotconnect2. I can see "Volumio" under the "Connect to device" popup but I am unable to make connect. I am already on volspotconnect2 0.9.3 installed using commands from github. I have enabled debug mode. How do I access the debug log?

Spotify Connect

PostPosted: Mon Apr 08 2019 14:29
by ashthespy
yungyaw wrote:Lately I have been having trouble using volspotconnect2. I can see "Volumio" under the "Connect to device" popup but I am unable to make connect. I am already on volspotconnect2 0.9.3 installed using commands from github. I have enabled debug mode. How do I access the debug log?


Probably failing with the mixer setup..

Code: Select all
sudo journalctl -f -o cat -u volspotconnect2.service

Spotify Connect

PostPosted: Mon Apr 08 2019 14:34
by ashthespy
mleuba wrote:I’m a new owner of Primo and first time Volumio user. The Spotify Connect plugins are virtually non functional. The only tracks that are available are in the What’s New folder, other folders appear to have playlists but none of them actually function, click on the playlist and nothing happens. It’s really virtually useless as is. I saw in a development thread someone has fixed Spotify Connect or provided an alternative but I don’t see it as a plugin so it’s not available to me. Unfortunate because I’m a Spotify user And wanted to stream both Spotify and my music through Volumio.


You seem to be confusing Spotify vs Spotify Connect. Take a look at the post above yours for the difference!

Spotify Connect

PostPosted: Wed Apr 10 2019 17:39
by Milbebonbon605
it´s me again.. :D

now with 0.9.1 there is minimal delay - Maybe 1 max 2 sec, this is really OK!

thanks a lot

Spotify Connect

PostPosted: Thu Apr 11 2019 01:58
by yungyaw
ashthespy wrote:
yungyaw wrote:Lately I have been having trouble using volspotconnect2. I can see "Volumio" under the "Connect to device" popup but I am unable to make connect. I am already on volspotconnect2 0.9.3 installed using commands from github. I have enabled debug mode. How do I access the debug log?


Probably failing with the mixer setup..

Code: Select all
sudo journalctl -f -o cat -u volspotconnect2.service


Hi ashthespy,

Thanks for your reply. I saw this when trying to connect to Volumio under Spotify Device List.

Code: Select all
[Vollibrespot] mdns::fsm: received question: IN _apple-pairable._tcp.local
[Vollibrespot] librespot_connect::discovery: Post "/" {}
[Vollibrespot] : Connecting to AP "gae2-accesspoint-b-8zx2.ap.spotify.com:4070"
[Vollibrespot] mdns::fsm: received question: IN _companion-link._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _homekit._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _airplay._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _sleep-proxy._udp.local
[Vollibrespot] mdns::fsm: received question: IN 40:4d:7f:6a:80:90@fe80::424d:7fff:fe6a:8090._apple-mobdev2._tcp.local
[Vollibrespot] mdns::fsm: received question: IN 40:4d:7f:6a:80:90@fe80::424d:7fff:fe6a:8090._apple-mobdev2._tcp.local
[Vollibrespot] mdns::fsm: received question: IN 40:4d:7f:6a:80:90@fe80::424d:7fff:fe6a:8090._apple-mobdev2._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _companion-link._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _homekit._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _airplay._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _sleep-proxy._udp.local
[Vollibrespot] mdns::fsm: received question: IN _companion-link._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _homekit._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _airplay._tcp.local
[Vollibrespot] mdns::fsm: received question: IN 04255CB411F0@Volumio._raop._tcp.local
[Vollibrespot] mdns::fsm: received question: IN _sleep-proxy._udp.local


Can you tell what is my volspotconnect2 problem from the above?

FYI, I tried all Mixer Type settings (Hardware, Software, None). All same result.