Tidal playlists not working on 2.673

Need help with MyVolumio? That's the place to get help and support (MYVOLUMIO ONLY)

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Tidal playlists not working on 2.673

Postby JochenS » Wed Dec 04 2019 20:23

I upgraded from free plan to hear Tidal. I have tidal premium.

Single tracks can be played, but the big play button in playlists doesn't work. The same applies for favorite albums.

Procedure to reproduce:
- Tidal
- my musik - playlists
- Click on one Playlist
- Click on the Play button on top
- sometimes the first track is added to the queue.

Also from the list of Playlist with the .... button no option works (replace queue, add to queue, create new playlist)

In this state the software doesn't makes sense for me....
Random avatar
JochenS
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Wed Dec 04 2019 20:16

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Tidal playlists not working on 2.673

Postby michelangelo » Wed Dec 04 2019 22:44

Hi Jochen,
you can have dedicated support since you are a myvolumio user.
https://volumio.github.io/docs/User_Man ... oting.html

Paste the log and send it via mail to info at volumio dot org

So I will see what happens to your side and be able to help
User avatar
michelangelo
Founder
 
Posts: 4422
Joined: Sun Dec 15 2013 23:18


Tidal playlists not working on 2.673

Postby DBMandrake » Yesterday 12:15

Could be a duplicate of the issue I reported here ?

adding-songs-play-queue-very-slow-tidal-t13385.html

How many songs are in the playlist ? Try clicking on the large play button at the top of a playlist and then wait a few minutes to see if anything happens..

For me a playlist with 270 songs in it takes over a minute to queue for playback from Tidal, and during that time it seems that nothing is happening...

Also try a playlist with only a few songs in it to see if it is related to the length of the playlist.
Random avatar
DBMandrake
Serious Listener
Serious Listener
 
Posts: 56
Joined: Fri Sep 29 2017 19:45


Tidal playlists not working on 2.673

Postby JochenS » Yesterday 21:12

DBMandrake this could be a similar issue. My playlist is pretty long approx 250 titles and with luck the first was put to the queue.

I have tried now a shorter one with approx 20 titles. Here the first 4 are coming to the play list.

Log is on the way ..http://logs.volumio.org/volumio/QM7U8Fo.html

This is my old Raspi Model B Revision 2.0 (512MB). Is this too much?
Random avatar
JochenS
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Wed Dec 04 2019 20:16


Tidal playlists not working on 2.673

Postby michelangelo » Yesterday 21:54

Very interesting.
To queue an entire playlist, lot of concurrent calls to TIDAL API are to be made. So yes, an old PI might really suffer from that.
My suggestion: please upgrade to a PI3,PI4 or Tinkerboard. The user experience is so much better for the little investment ;)
User avatar
michelangelo
Founder
 
Posts: 4422
Joined: Sun Dec 15 2013 23:18


Tidal playlists not working on 2.673

Postby DBMandrake » Yesterday 22:05

Yes - I have a Pi 4 and it runs Volumio much, much faster than my Pi 2 did and somewhat faster than my Cubox-i did. So I would imagine that an original Pi 1 would be a struggle. I would recommend the upgrade to a Pi 4 especially if you use a USB sound interface or wish to in the future.

However there is still something wrong with the Tidal integration at the moment if it is taking over 60 seconds on a Pi 4 to queue a playlist with 270 songs in it when the same length playlist is queued and starts playing in under one second using Qobuz. Hopefully this can be fixed.
Random avatar
DBMandrake
Serious Listener
Serious Listener
 
Posts: 56
Joined: Fri Sep 29 2017 19:45


Tidal playlists not working on 2.673

Postby michelangelo » Yesterday 23:28

DBMandrake wrote:Yes - I have a Pi 4 and it runs Volumio much, much faster than my Pi 2 did and somewhat faster than my Cubox-i did. So I would imagine that an original Pi 1 would be a struggle. I would recommend the upgrade to a Pi 4 especially if you use a USB sound interface or wish to in the future.

However there is still something wrong with the Tidal integration at the moment if it is taking over 60 seconds on a Pi 4 to queue a playlist with 270 songs in it when the same length playlist is queued and starts playing in under one second using Qobuz. Hopefully this can be fixed.

Yes indeed, we will work on that
User avatar
michelangelo
Founder
 
Posts: 4422
Joined: Sun Dec 15 2013 23:18


Return to MyVolumio Help and Support

Who is online

Users browsing this forum: No registered users and 0 guests