M2Tech HiFace Pop/Crack sound when next track is pressed

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

M2Tech HiFace Pop/Crack sound when next track is pressed

Postby Stoiker » Tue Dec 03 2019 23:12

Hi !

I am currently testing volumio on a Raspberry Pi3 with an M2Tech HiFace; everything in default config.

The DSP is recognized and plays fine, however when I skip to the next track a crack/pop noise is produced. Transition between tracks without interaction (thus the queue just roles) works fine.

I already tried to force the output format via mpd.conf, which did not help.

Browsing the internet I found the troubleshooting guide: http://www.sound-pixel.com/files/product_pdf/hiFace%20-%20Official%20Troubleshooting%20and%20FAQ%20-%2025-3-13.pdf which states on the second page that it is a 'hiFace typical behaviour related to buffers management' (found via: https://sourceforge.net/p/alsa/mailman/message/30854249/) - Not sure how to deal with that.

Next steps would be a non altered DSP output and tinkering with ALSA.

Did anyone encounter this problem or something similar? Thx!
User avatar
Stoiker
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Tue Dec 03 2019 23:02

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


M2Tech HiFace Pop/Crack sound when next track is pressed

Postby USER » Wed Dec 04 2019 17:00

Hi Stoiker,

I'm currently using a M2 Tech high face DAC along with a pi3 B+ with volumio version 2.657 and have not any issues with popping or clicking.
Some where I read the newer M2 Tech had issues. I'm using an older one about 4 years old.
Random avatar
USER
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Tue Oct 01 2019 17:20


M2Tech HiFace Pop/Crack sound when next track is pressed

Postby Stoiker » Wed Dec 04 2019 23:39

Hi!

Thx for the reply, I also have this DAC in another setup, indeed a great DAC.
In the problematic setup it is the first one over there: http://www.newaudio.it/m2tech5.htm (no typo), which is also an older model.

Supplementary information about the setup:
* From the DSP it goes directly to a Behringer DEQ2496 which also performs the DA-part; then to the amp and to the speakers.
* The click/pop noise is proportional to the volume setup in the software mixer

I need to investigate further
User avatar
Stoiker
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Tue Dec 03 2019 23:02


Return to Help

Who is online

Users browsing this forum: No registered users and 9 guests