Issues with scan of music files on NAS

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Issues with scan of music files on NAS

Postby aibohphobia » Fri Oct 04 2019 23:31

I'm setting up my first Volumio build (never had a need before). And I've added my NAS music location, but when I scan, the number of artists increases then disappears. Gets to mid 100-200 and then disappears.

Spec...
    Raspberry Pi A+ (I had it spare),
    16GB generic card,
    Amazon Kindle Fire charger,
    GPIO control v0.0.1
    Volumio v2.619 image (2019-09-24)
    Static IP,
    USB ethernet adapter,
    3.5mm audio out.

NAS mount options...
    IP = 10.0.0.x
    Path = audio
    Options = ro,vers=1.0,nosetuids,sec=ntlm,nounix

I start a rescan in the My Music section and it will fairly quickly add music to the database. But after it's gotten to about 150 artists, no artists will be found in the library an nothing is in the table on the My Music. After this it will continue to flash the activity and network lights (as if continuing to add artists), but nothing is found in Web GUI. I've left the Pi overnight and in the morning there is nothing in the library and table in Settings -> My music is empty.

I've tried rebooting after the rescan but I still cannot find my music anywhere. I was wondering if it is a RAM issue, as I'm using the A+ with only 256MB of RAM, the Web UI is fairly slow. I used an A+ as I had one knocking around spare (same with the USB ehternet)!

Any help would be great.
Random avatar
aibohphobia
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Fri Oct 04 2019 13:58

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Issues with scan of music files on NAS

Postby fafa » Sat Oct 05 2019 15:33

I got similar issue after upgrading from 2.587 to 2.599 , NAS scan stop at the begging without discovering most of the Album on NAS

I deleted and declared again and as well made a from scratch installation without success.
As well, I tested the disk. No issue.

And last upgrade to 2.632 did not helps.

It is just stopping at 47 albums - that is all and mdt.log and volumio.log doesn't not report any particular error.

I generated logs and debug info and send it here :
http://logs.volumio.org/volumio/HiTrFEa.html

Thank you very much for your help.
Random avatar
fafa
Fresh off the boat
Fresh off the boat
 
Posts: 7
Joined: Wed May 11 2016 20:32


Issues with scan of music files on NAS

Postby martinmos » Sat Oct 05 2019 18:28

I got exactly same experience on x86 platform, scanning of NAS drive got just frozen. Nothing helped, new fresh install, another device, etc.
My library on NAS is about 3 TB mostly hi-res music.

Thank you in advance for help.
Random avatar
martinmos
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Sat Oct 05 2019 18:21


Issues with scan of music files on NAS

Postby michelangelo » Sun Oct 06 2019 13:57

Nothing obvious from the logs...
We are investigating
User avatar
michelangelo
Founder
 
Posts: 4320
Joined: Sun Dec 15 2013 23:18


Issues with scan of music files on NAS

Postby fafa » Sat Oct 12 2019 12:47

@
Do you need another set of logs ? issue is still there...
Random avatar
fafa
Fresh off the boat
Fresh off the boat
 
Posts: 7
Joined: Wed May 11 2016 20:32


Return to Help

Who is online

Users browsing this forum: No registered users and 10 guests
cron