How to get the Spotify plugin working

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

How to get the Spotify plugin working

Postby realbosselarsson » Sun Oct 13 2019 17:23

Awesome!
Thanks, I was a bit let down that the Spotify portion of Volumio was so slow and weird but this fixed it.
User avatar
realbosselarsson
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Wed Sep 25 2019 15:06

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


How to get the Spotify plugin working

Postby jparis » Tue Oct 15 2019 17:52

Hi skikirkwood,

Just for you to know that my Spotify account was in a weird state (it's a family premium account and someone changed the address of the main account so the rest of them went KO) and that was the reason of the failure.

Etched last version, follow your instructions at https://forum.volumio.org/how-get-the-spotify-plugin-working-t12368.html and everything working again.

Thank you so much for your support and for the working plugin!
Random avatar
jparis
Fresh off the boat
Fresh off the boat
 
Posts: 7
Joined: Tue May 14 2019 19:35


How to get the Spotify plugin working

Postby skikirkwood » Wed Oct 16 2019 15:26

jparis wrote:Hi skikirkwood,

Just for you to know that my Spotify account was in a weird state (it's a family premium account and someone changed the address of the main account so the rest of them went KO) and that was the reason of the failure.

Etched last version, follow your instructions at https://forum.volumio.org/how-get-the-spotify-plugin-working-t12368.html and everything working again.

Thank you so much for your support and for the working plugin!


Great to here! I have 4 Pis in my house all running Volumio and the Spotify plugin.
Volumio 2 on Raspberry Pi 3 B+, Schiit Modi 2 Multibit DAC, Volumio 2 on Raspberry Pi 3, IQAudio Pi-DAC+, Schiit Freya preamp, Bryston 3b power amp, B&W 803 speakers
User avatar
skikirkwood
Objectivist
Objectivist
 
Posts: 289
Joined: Thu Jan 08 2015 17:16
Location: Los Altos Hills, California


How to get the Spotify plugin working

Postby aleksije » Fri Oct 18 2019 16:55

After installing custom plugin and entering refresh token, I am able to access playlists, however, none of the songs could be played.

The log shows error:


[2019-10-18T16:53:26.670Z - info: {"uri":"spotify:track:5j6ZZwA9BnxZi5Bk0Ng4jB","service":"spop","name":"Heroes - 1999 Remaster","artist":"David Bowie","album":"Heroes","type":"song","duration":370,"tracknumber":3,"albumart":"https://i.scdn.co/image/ab67616d0000b273b2232f2b7451f332de987d36","samplerate":"320Kbps","bitdepth":"16 bit","trackType":"spotify"}
2019-10-18T16:53:26.670Z - info: [1571417606670] ControllerSpop::sendSpopCommand
2019-10-18T16:53:26.671Z - info: ADDING DEFER FOR COMMAND uplay
2019-10-18T16:53:26.672Z - info: SPOP command error:
2019-10-18T16:53:26.673Z - info: message=This socket has been ended by the other party, stack=Error: This socket has been ended by the other party


Any thoughts on this?
Random avatar
aleksije
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Fri Oct 18 2019 16:50


How to get the Spotify plugin working

Postby thorsten » Mon Oct 28 2019 10:48

Hi skikirkwood,

Also a big THANK YOU from me and my family! Got it up and running on my 4 RPi 3+ effortless! Great work!
Volumio on RPi 3B+ with 2x HifiberryAmp2, 1x Hifiberry DAC+, 1x Hifiberry DIGI
Controlled by web, iOS- and Android (ver.8) Apps
Random avatar
thorsten
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Fri Sep 13 2019 17:58


How to get the Spotify plugin working

Postby skikirkwood » Mon Oct 28 2019 18:55

thorsten wrote:Hi skikirkwood,

Also a big THANK YOU from me and my family! Got it up and running on my 4 RPi 3+ effortless! Great work!


:)
Volumio 2 on Raspberry Pi 3 B+, Schiit Modi 2 Multibit DAC, Volumio 2 on Raspberry Pi 3, IQAudio Pi-DAC+, Schiit Freya preamp, Bryston 3b power amp, B&W 803 speakers
User avatar
skikirkwood
Objectivist
Objectivist
 
Posts: 289
Joined: Thu Jan 08 2015 17:16
Location: Los Altos Hills, California


How to get the Spotify plugin working

Postby Hour Hero Yes » Fri Nov 01 2019 18:21

Hi,
I'm trying to downlad the plugin but I get the following error.

Code: Select all
volumio@volumio:~$ wget https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip
converted 'https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip' (ANSI_X3.4-1968) -> 'https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip' (UTF-8)
--2019-11-01 18:19:47--  https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip
Resolving github.com (github.com)... failed: Name or service not known.
wget: unable to resolve host address 'github.com'


Any thoughts?
User avatar
Hour Hero Yes
Fresh off the boat
Fresh off the boat
 
Posts: 6
Joined: Tue Jul 30 2019 09:24


How to get the Spotify plugin working

Postby 01findus » Tue Nov 05 2019 01:27

Works with Volumio 2.657 and the Custom Plug-In from skikirkwood,

Also a big THANK YOU from me! Great Job!

Got the following Error on installation, but it worked anyway:
Code: Select all
Status :Checking for duplicate plugin
Progress: 60
Status :Copying Plugin into location
Progress: 70
Status :Installing dependencies
Progress: 0
Status :The following error occurred when installing the plugin: Error
Random avatar
01findus
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Fri Jan 22 2016 22:33


How to get the Spotify plugin working

Postby skikirkwood » Tue Nov 05 2019 16:37

Hour Hero Yes wrote:Hi,
I'm trying to downlad the plugin but I get the following error.

Code: Select all
volumio@volumio:~$ wget https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip
converted 'https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip' (ANSI_X3.4-1968) -> 'https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip' (UTF-8)
--2019-11-01 18:19:47--  https://github.com/majko96/volumio-plugins/raw/master/plugins/music_service/spotify/spotify.zip
Resolving github.com (github.com)... failed: Name or service not known.
wget: unable to resolve host address 'github.com'


Any thoughts?

Looks like there was a networking issue on your Volumio device as it could not resolve the github.com domain name.
Volumio 2 on Raspberry Pi 3 B+, Schiit Modi 2 Multibit DAC, Volumio 2 on Raspberry Pi 3, IQAudio Pi-DAC+, Schiit Freya preamp, Bryston 3b power amp, B&W 803 speakers
User avatar
skikirkwood
Objectivist
Objectivist
 
Posts: 289
Joined: Thu Jan 08 2015 17:16
Location: Los Altos Hills, California


How to get the Spotify plugin working

Postby Zathras » Fri Nov 08 2019 20:57

Ok for anyone who has it act like it is working but doesn't - make sure you use the DEVICE USERNAME and PASSWORD for spotify.... Ignore deleted problems :)
Random avatar
Zathras
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Thu Nov 07 2019 19:50

Previous

Return to Help

Who is online

Users browsing this forum: MSN [Bot] and 6 guests