HELP NEEDED TO TEST THE NEW UPDATER

Here you can find all important communications from Volumio's staff

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

HELP NEEDED TO TEST THE NEW UPDATER

Postby Saiyato » Tue Sep 19 2017 20:42

Also, factory reset doesn't seem to work anymore with version 2.272 on raspberry pi
Just.Love.Music.
User avatar
Saiyato
Golden Ear
Golden Ear
 
Posts: 569
Joined: Wed Dec 23 2015 07:58
Location: Woudenberg, Netherlands

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby JimCo06 » Thu Sep 28 2017 20:43

Updated to 2.272 on my RPi3 and I was able to load my library without having the system freeze. I do have a few AIFF albums and they don't seem to cause any problems either.

However, about 1% of my albums are missing artwork. Every song in my library has the album art embedded and it all shows properly in other programs (iTunes, foobar, JRiver, etc.). I also have problems browsing my library. Even though I have the "Sort Artists By" set to albumartist I am still getting a large number of artists that are not albumartists listed. And when sorting by Album all of my compilation albums show up as a separate album for each song artist. Ironically, the total album count is correct. I have tried several fixes for each of these problems but so far nothing has worked.
Random avatar
JimCo06
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Wed Jan 11 2017 23:16


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby Hf4d2skwk8 » Fri Sep 29 2017 13:33

Updated to latest 2279 and I recognized that 24bit 192khz tracks aren't working anymore with my Allo DigiOne. Anybody else the problem?
Random avatar
Hf4d2skwk8
Sunday DIYer
Sunday DIYer
 
Posts: 39
Joined: Sun Jun 25 2017 12:05


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby lochimeng » Tue Oct 03 2017 11:37

Hf4d2skwk8 wrote:Updated to latest 2279 and I recognized that 24bit 192khz tracks aren't working anymore with my Allo DigiOne. Anybody else the problem?


Same problem, then I turn off the I2S, reboot, turn on I2S again, reboot, problem is fixed.
Random avatar
lochimeng
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Thu Sep 14 2017 08:24


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby Hf4d2skwk8 » Sat Oct 07 2017 08:35

thank you for your hint, but unfortunately this doesn't work for me .

Feedback 2.282:
works pretty well. updating large database works flawless for me.

The browse icon always rotates, don't know why, also after the manual update scan is already done.

I don't know any alternative to a ssh script for shutting down an usb harddisk.

Is there any possibility to implement a web shutdown including usb harddisk?
Random avatar
Hf4d2skwk8
Sunday DIYer
Sunday DIYer
 
Posts: 39
Joined: Sun Jun 25 2017 12:05


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby michelangelo » Tue Oct 10 2017 18:02

We had some issues this weekend with the latest X86 release. So, if someone is able to put his X86 device in test mode and test the updater (along with factory reset and every operation you might think of) that would be a great help for us.

Let me know ;)
User avatar
michelangelo
Founder
 
Posts: 4145
Joined: Sun Dec 15 2013 23:18


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby michelangelo » Sun Oct 29 2017 23:03

Please guys, help us with X86 testing.
Put your device in test mode and try to update up to 2.301

This is extremely needed, let us know

PS: If you update from a version higher than 2.201 its suggested to do a factory reset before updating
User avatar
michelangelo
Founder
 
Posts: 4145
Joined: Sun Dec 15 2013 23:18


HELP NEEDED TO TEST THE NEW UPDATER

Postby stosoorok » Wed Nov 01 2017 21:59

Factory reset bricked x86 v. 2.256 - 11.08.2017, won't boot any more.

e.

Clean install -> System Version: 2.285 Released Sat Oct 7 23:48:16 -> Update to v2.301 -> OK!
Random avatar
stosoorok
Sunday DIYer
Sunday DIYer
 
Posts: 31
Joined: Fri Jun 30 2017 23:30


HELP NEEDED TO TEST THE NEW UPDATER

Postby gkkpch » Wed Nov 01 2017 23:39

Thanks for your valuable feedback, this may help others.
A factory reset on versions below 2.279 still works the old way and can be used as suggested.

However, using a version higher then 2.279 as a starting point is not a good idea, sorry about that.
During the new factory reset, one particular file in the boot partition is being restored which should actually be left untouched.
It is against the syslinux boot specifications and can lead to a boot error like yours, depending on situation and hardware.
This has been fixed and is one of the reasons why Michelangelo is now calling for a new series of tests.

-- Gé --
Volumio OS Developer

You like my work? Then what about buying me a beer :)
User avatar
gkkpch
Moderator
 
Posts: 1565
Joined: Mon Dec 29 2014 22:38
Location: Bodensee, Switzerland


Re: HELP NEEDED TO TEST THE NEW UPDATER

Postby stosoorok » Tue Nov 14 2017 18:10

x86 vBox VM - v2.129 - 25.03.17 without factory reset -> v2.279 - 29.10.17 -> OK
x86 vBox VM - v2.279 - 29.10.17 without factory reset -> v2.309 - 04.11.17 -> OK

VirtualBox_volumio2_10_11_2017_17_34_59.png
VirtualBox_volumio2_10_11_2017_17_34_59.png (1.19 MiB) Viewed 695 times


8-)
Random avatar
stosoorok
Sunday DIYer
Sunday DIYer
 
Posts: 31
Joined: Fri Jun 30 2017 23:30

Previous

Return to Staff comunications

Who is online

Users browsing this forum: No registered users and 0 guests