[PLUGIN] Google Music Plugin available to test

Discuss, contribute and orient Volumio development!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

[PLUGIN] Google Music Plugin available to test

Postby jjazz » Sat Dec 08 2018 23:46

Hi there,

I just opened a PR for a Google Music Plugin that uses GMusicProxy. I'd appreciate feedback from anyone available to test. To run, you need to build/install a branch of GMusicProxy available here. I had to add some JSON endpoints to support the functionality in Volumio and it hasn't been merged to master yet.

The plugin source is available here and can be installed following the instructions in Volumio Documentation

Currently allows for playing music from your Library, Playlists, and Stations. The search capability has a few nice features:
Standard search by keywords - e.g.
Code: Select all
John Coltrane

Album or Artist search - e.g.
Code: Select all
Michael Jackson type:artist
or
Code: Select all
type:album title:Giant Steps
or
Code: Select all
stairway artist:Led Zeppelin


Hope some people find this useful.

Justin
Random avatar
jjazz
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Wed Dec 05 2018 21:18

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


[PLUGIN] Google Music Plugin available to test

Postby Mansunz » Sun Mar 17 2019 08:10

Thanks. Any update on the testing?
Random avatar
Mansunz
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Fri Aug 24 2018 09:11


[PLUGIN] Google Music Plugin available to test

Postby martin.klein.austria » Mon Apr 29 2019 19:30

I tried to install your updated GMusicProxy as described. The command "sudo pip install -r requirements.txt" resultet in a "Value error". See below:

Code: Select all
volumio@volumio:~/gmusicproxy$ sudo pip install -r requirements.txt --allow-external eyed3 --allow-unverified eyed3
[sudo] password for volumio:
Obtaining file:///home/volumio/gmusicproxy (from -r requirements.txt (line 3))
  Running setup.py (path:/home/volumio/gmusicproxy/setup.py) egg_info for package from file:///home/volumio/gmusicproxy

Downloading/unpacking gmusicapi>=10.1.0,<11.0.0 (from gmusicproxy==1.0.9b2->-r requirements.txt (line 3))
  Downloading gmusicapi-10.1.2.tar.gz (166kB): 166kB downloaded
  Running setup.py (path:/tmp/pip-build-t2ixoR/gmusicapi/setup.py) egg_info for package gmusicapi

    warning: no previously-included files matching '_local_*.py' found anywhere in distribution
Downloading/unpacking netifaces>=0.10.4 (from gmusicproxy==1.0.9b2->-r requirements.txt (line 3))
  Downloading netifaces-0.10.9.tar.gz
  Running setup.py (path:/tmp/pip-build-t2ixoR/netifaces/setup.py) egg_info for package netifaces

Requirement already satisfied (use --upgrade to upgrade): pyxdg>=0.25 in /usr/lib/python2.7/dist-packages (from gmusicproxy==1.0.9b2->-r requirements.txt (line 3))
Downloading/unpacking eyed3>=0.7.8 (from gmusicproxy==1.0.9b2->-r requirements.txt (line 3))
  Downloading eyeD3-0.8.10-py2.py3-none-any.whl (147kB): 147kB downloaded
Cleaning up...
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 290, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1266, in prepare_files
    req_to_install.extras):
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2401, in requires
    dm = self._dep_map
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2597, in _dep_map
    self.__dep_map = self._compute_dependencies()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2621, in _compute_dependencies
    parsed = next(parse_requirements(distvers))
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 49, in <lambda>
    next = lambda o: o.next()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2721, in parse_requirements
    "version spec")
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2686, in scan_list
    raise ValueError(msg, line, "at", line[p:])
ValueError: ('Expected version spec in', 'pylast ~=2.0', 'at', ' ~=2.0')


Any help appreciated. Regards Martin.
Random avatar
martin.klein.austria
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Mon Apr 29 2019 19:17


[PLUGIN] Google Music Plugin available to test

Postby martin.klein.austria » Sun May 05 2019 17:17

removed this post
Last edited by martin.klein.austria on Mon May 06 2019 17:19, edited 1 time in total.
Random avatar
martin.klein.austria
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Mon Apr 29 2019 19:17


[PLUGIN] Google Music Plugin available to test

Postby martin.klein.austria » Mon May 06 2019 17:09

In the meantime I found out that the MusicProxy Installation instructions missed 3 items:
1. pip install --upgrade pip
2. sudo apt-get install libxml2
3. sudo apt-get install libxslt

Then I could install gmusicproxy. But when I launch the proxy with
GMusicProxy --email xxxx@gmail.com --password xxxx
I get again error message:

volumio@volumio:~$ workon gmusicproxy
(gmusicproxy)volumio@volumio:~$ GMusicProxy --email: xxx@gmail.com --password:xxx
Traceback (most recent call last):
File "/home/volumio/.virtualenvs/gmusicproxy/bin/GMusicProxy", line 4, in <module>
__import__('pkg_resources').require('gmusicproxy==1.0.9b2')
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 2876, in <module>
working_set = WorkingSet._build_master()
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 449, in _build_master
ws.require(__requires__)
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 745, in require
needed = self.resolve(parse_requirements(requirements))
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 645, in resolve
requirements.extend(dist.requires(req.extras)[::-1])
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 2401, in requires
dm = self._dep_map
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 2597, in _dep_map
self.__dep_map = self._compute_dependencies()
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 2621, in _compute_dependencies
parsed = next(parse_requirements(distvers))
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 49, in <lambda>
next = lambda o: o.next()
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 2721, in parse_requirements
"version spec")
File "/home/volumio/.virtualenvs/gmusicproxy/local/lib/python2.7/site-packages/pkg_resources.py", line 2686, in scan_list
raise ValueError(msg, line, "at", line[p:])
ValueError: ('Expected version spec in', 'pylast ~=2.0', 'at', ' ~=2.0')
Random avatar
martin.klein.austria
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Mon Apr 29 2019 19:17


[PLUGIN] Google Music Plugin available to test

Postby martin.klein.austria » Mon May 06 2019 17:15

So I tried to get on with installation of the volumio gmusic plugin.
Downloaded the gmusic_proxy.zip
Unziped with miniunzip
go to the unziped folder
Install with "volumio plugin install"

And get Error message: "no package found"...

Any help appreciated
Regards Martin
Last edited by martin.klein.austria on Tue May 07 2019 18:37, edited 1 time in total.
Random avatar
martin.klein.austria
Fresh off the boat
Fresh off the boat
 
Posts: 4
Joined: Mon Apr 29 2019 19:17


[PLUGIN] Google Music Plugin available to test

Postby chsims1 » Tue May 07 2019 08:33

Martin, it's the bb software for the forum that is marking your posts "for approval", not a human administrator. Apologies for this, but hopefully moving to a new forum host in the not too distant future.
New to Volumio? Please read the Quick Start Guide to get your system up and running :). FAQs? Docs?
User avatar
chsims1
Moderator
 
Posts: 1818
Joined: Sat Aug 02 2014 10:44
Location: East Yorkshire, UK


Return to Development talks

Who is online

Users browsing this forum: No registered users and 4 guests